Sneak Peek at Moodle 2.1’s changes and features

4
1252

If you’re curious what the end of June will bring with the release of Moodle 2.1 you can checkout the yet to be released Moodle 2.1 Release Notes page at Moodle.org.

Included in this upcoming release is a revamp of the question engine (developed by the Open University).  You can read more on the release notes page but it seems to be a substantial upgrade/change from what is currently available in Moodle.

Full documentation for the new Quiz Engine is available at Development:Question_Engine_2 at Moodle.org.

In addition to these changes it appears that there will also be a clone/copy resource tool for easily creating new/similar resources and activities to what are already used in a course.

Excited for Moodle 2.1 yet?

  • Did restoring a 1.9 course backup into 2.x get dropped from the 2.1 to-do list? If so that’s really a bummer, it’s the one feature I was really looking forward to to ease the transition this summer.

  • Joseph Thibault

    Danny, I think it’s more the case that it just wasn’t listed on that sneak peak. I’ve heard it mentioned recently in the Developer Meeting notes and it’s still listed on the site as coming for 2.1 [link to the docs]. I’m certain it not being listed on the page above is simply a product of the collaborative nature of the docs being created.

  • Lars

    @Joseph Thibault

    The Moodle 2.1 Release Notes, list that:

    “When upgrading to Moodle 2.1, you must first upgrade to Moodle 2.0 or later.”

    The Moodle Roadmap says that it will be possible to “Restore 1.9 backups directly.” Since moodle 2.0 does not allow upgrading of moodle 1.9 courses, both of these can’t be true, can they?

    -Lars.

  • Joseph Thibault

    Lars, my understanding is that upgrading your 1.9 site to 2.0 will convert all current courses on that 1.9 site to be converted along with the site to Moodle 2.0. Thereafter you can upgrade to 2.1 and any other courses you might have from pre 2.0 will be restorable to the new system as long as the new backup/restore of 1.9 to 2.1 is indeed functioning.